ASA 5505 won't play ball (port forwarding trouble)

Yonzie

Limp Gawd
Joined
Jul 6, 2005
Messages
184
A while ago, I moved, and after the move I'm having issues with my 5505 and port forwarding.
Before, I had an ethernet drop in the apartment, plugged that into the 5505, and it (more or less) Just Worked (tm).
Now, I have cable internet, and I have to use the cable companys Netgear CVG824G.
This means the 5505 now has a local IP (192.168.0.10).
I have told the Netgear to treat the 5505 as the DMZ, and I have verified that it actually does this.
Unfortunately, behind the Cisco, things are not as bright. I have issues with timeouts in MSN messenger, I can't access anything from outside, etc.
The network looks like this:
Internet <-> Netgear <-> 5505 <-> Switch <-> computer

Someone please tell me what I'm doing wrong.
I have pasted my config here in case it helps. I guess something might have gotten screwed up in the move/reconfig. It seems right to me, but this isn't exactly my home turf ;)

Thanks,
Jens.

Code:
ASA Version 7.2(2) 
!
hostname xxx
domain-name xxx
enable password xxx encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute 
!
interface Ethernet0/0
 description Outside network (ISP network)
 switchport access vlan 2
!
interface Ethernet0/1
 description Inside wired network
!
interface Ethernet0/2
 description Inside wireless network
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd xxx encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name xxx
access-list outside_access_in extended permit tcp any interface outside eq 16789 
access-list outside_access_in extended permit tcp any interface outside eq ssh 
access-list outside_access_in extended permit icmp any interface outside 
access-list outside_access_in extended permit icmp6 any interface outside 
access-list outside_access_in extended permit udp any interface outside eq 16789 
access-list name extended permit icmp any interface outside 
access-list inside_access_out extended permit ip any any inactive 
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip verify reverse-path interface outside
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
asdm image disk0:/asdm-522.bin
asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 192.168.1.0 255.255.255.0
static (inside,outside) tcp interface ssh 192.168.1.10 ssh netmask 255.255.255.255 
static (inside,outside) tcp interface 16789 192.168.1.50 16789 netmask 255.255.255.255 
static (inside,outside) udp interface 16789 192.168.1.50 16789 netmask 255.255.255.255 
access-group inside_access_out out interface inside
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
sysopt noproxyarp inside
sysopt noproxyarp outside
no vpn-addr-assign aaa
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
dhcpd dns 82.143.255.20 193.162.159.194
dhcpd auto_config outside
!
dhcpd address 192.168.1.64-192.168.1.95 inside
dhcpd enable inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:xxx
 
Well you're NATing twice, which is one issue. Why use their equipment? If it's a modem/router combo, can you configure it in bridge mode?
 
no nat (inside) 1 192.168.1.0 255.255.255.0
no access-group inside_access_out out interface inside
nat (inside) 1 0.0.0.0 0.0.0.0

That should do it.
 
Back
Top